hide

Could not connect to the database. Connector returned number

Post By:user_3500 | Reply

Using:

joomla 2.5.8
xampp 1.7.3 (running apache and mysql)
OS: windows 7 home

I am installing locally, same problem also when i install in the server
I tried root with no password but error came as

"Could not connect to the database. Connector returned number: Unable to connect to the Database: Could not connect to MySQL."

I checked the http://localhost/phpmyadmin/, it says ERROR

"#1045 - Access denied for user 'root'@'localhost' (using password: NO) "

please help. thanks.
user_28Tue, 20 Nov 2012

user_3500Tue, 20 Nov 2012

user_28Mon, 19 Nov 2012

When you click Security from the XAMPP control page http://localhost/security/index.php do you see everything displayed as follows:

Attachment:
xampp_sec_page.jpg


Are you running Apache and MySQL within the XAMPP package (its default installation) or have you enabled Apache and MySQL as Windows services?

user_399Sat, 17 Nov 2012

user_3500Sat, 17 Nov 2012

I really appreciate for the questions and feedback, here are my following actions i made:

How did you install xampp ? the exe that auto installed ?
I followed this installation steps from here
http://docs.joomla.org/Use_Joomla!_on_your_own_computer

Did you change the installation path from C:xampp ?
no change, same in C:xampp

Did you run security and change the default settings ?(no need to run security on a PC)
i did not run security

Did you start the services in the xampp Control Panel ?(you could set the short cut to xampp 'run as administrator'.
i start the services of xampp, apache and mysql, and i also tried run as admin but same problem

What happens when you put http://localhost into your Browser ? Does it redirect to http://localhost/xampp ?
http://localhost/xampp page is working fine

Are you reaching http://localhost/phpmyadmin from the link in http://localhost/xampp ?
yes, but same error, "#1045 - Access denied for user 'root'@'localhost' (using password: NO)"I really appreciate for the questions and feedback, here are my following actions i made:

How did you install xampp ? the exe that auto installed ?
I followed this installation steps from here
http://docs.joomla.org/Use_Joomla!_on_your_own_computer

Did you change the installation path from C:xampp ?
no change, same in C:xampp

Did you run security and change the default settings ?(no need to run security on a PC)
i did not run security

Did you start the services in the xampp Control Panel ?(you could set the short cut to xampp 'run as administrator'.
i start the services of xampp, apache and mysql, and i also tried run as admin but same problem

What happens when you put http://localhost into your Browser ? Does it redirect to http://localhost/xampp ?
http://localhost/xampp page is working fine

Are you reaching http://localhost/phpmyadmin from the link in http://localhost/xampp ?
yes, but same error, "#1045 - Access denied for user 'root'@'localhost' (using password: NO)"I really appreciate for the questions and feedback, here are my following actions i made:

How did you install xampp ? the exe that auto installed ?
I followed this installation steps from here
http://docs.joomla.org/Use_Joomla!_on_your_own_computer

Did you change the installation path from C:xampp ?
no change, same in C:xampp

Did you run security and change the default settings ?(no need to run security on a PC)
i did not run security

Did you start the services in the xampp Control Panel ?(you could set the short cut to xampp 'run as administrator'.
i start the services of xampp, apache and mysql, and i also tried run as admin but same problem

What happens when you put http://localhost into your Browser ? Does it redirect to http://localhost/xampp ?
http://localhost/xampp page is working fine

Are you reaching http://localhost/phpmyadmin from the link in http://localhost/xampp ?
yes, but same error, "#1045 - Access denied for user 'root'@'localhost' (using password: NO)"I really appreciate for the questions and feedback, here are my following actions i made:

How did you install xampp ? the exe that auto installed ?
I followed this installation steps from here
http://docs.joomla.org/Use_Joomla!_on_your_own_computer

Did you change the installation path from C:xampp ?
no change, same in C:xampp

Did you run security and change the default settings ?(no need to run security on a PC)
i did not run security

Did you start the services in the xampp Control Panel ?(you could set the short cut to xampp 'run as administrator'.
i start the services of xampp, apache and mysql, and i also tried run as admin but same problem

What happens when you put http://localhost into your Browser ? Does it redirect to http://localhost/xampp ?
http://localhost/xampp page is working fine

Are you reaching http://localhost/phpmyadmin from the link in http://localhost/xampp ?
yes, but same error, "#1045 - Access denied for user 'root'@'localhost' (using password: NO)"I really appreciate for the questions and feedback, here are my following actions i made:

How did you install xampp ? the exe that auto installed ?
I followed this installation steps from here
http://docs.joomla.org/Use_Joomla!_on_your_own_computer

Did you change the installation path from C:xampp ?
no change, same in C:xampp

Did you run security and change the default settings ?(no need to run security on a PC)
i did not run security

Did you start the services in the xampp Control Panel ?(you could set the short cut to xampp 'run as administrator'.
i start the services of xampp, apache and mysql, and i also tried run as admin but same problem

What happens when you put http://localhost into your Browser ? Does it redirect to http://localhost/xampp ?
http://localhost/xampp page is working fine

Are you reaching http://localhost/phpmyadmin from the link in http://localhost/xampp ?
yes, but same error, "#1045 - Access denied for user 'root'@'localhost' (using password: NO)"I really appreciate for the questions and feedback, here are my following actions i made:

How did you install xampp ? the exe that auto installed ?
I followed this installation steps from here
http://docs.joomla.org/Use_Joomla!_on_your_own_computer

Did you change the installation path from C:xampp ?
no change, same in C:xampp

Did you run security and change the default settings ?(no need to run security on a PC)
i did not run security

Did you start the services in the xampp Control Panel ?(you could set the short cut to xampp 'run as administrator'.
i start the services of xampp, apache and mysql, and i also tried run as admin but same problem

What happens when you put http://localhost into your Browser ? Does it redirect to http://localhost/xampp ?
http://localhost/xampp page is working fine

Are you reaching http://localhost/phpmyadmin from the link in http://localhost/xampp ?
yes, but same error, "#1045 - Access denied for user 'root'@'localhost' (using password: NO)"

user_399Fri, 16 Nov 2012

How did you install xampp ? the exe that auto installed ?
Did you change the installation path from C:xampp ?
Did you run security and change the default settings ?(no need to run security on a PC)
Did you start the services in the xampp Control Panel ?(you could set the short cut to xampp 'run as administrator'.
What happens when you put http://localhost into your Browser ? Does it redirect to http://localhost/xampp ?
Are you reaching http://localhost/phpmyadmin from the link in http://localhost/xampp ?How did you install xampp ? the exe that auto installed ?
Did you change the installation path from C:xampp ?
Did you run security and change the default settings ?(no need to run security on a PC)
Did you start the services in the xampp Control Panel ?(you could set the short cut to xampp 'run as administrator'.
What happens when you put http://localhost into your Browser ? Does it redirect to http://localhost/xampp ?
Are you reaching http://localhost/phpmyadmin from the link in http://localhost/xampp ?How did you install xampp ? the exe that auto installed ?
Did you change the installation path from C:xampp ?
Did you run security and change the default settings ?(no need to run security on a PC)
Did you start the services in the xampp Control Panel ?(you could set the short cut to xampp 'run as administrator'.
What happens when you put http://localhost into your Browser ? Does it redirect to http://localhost/xampp ?
Are you reaching http://localhost/phpmyadmin from the link in http://localhost/xampp ?How did you install xampp ? the exe that auto installed ?
Did you change the installation path from C:xampp ?
Did you run security and change the default settings ?(no need to run security on a PC)
Did you start the services in the xampp Control Panel ?(you could set the short cut to xampp 'run as administrator'.
What happens when you put http://localhost into your Browser ? Does it redirect to http://localhost/xampp ?
Are you reaching http://localhost/phpmyadmin from the link in http://localhost/xampp ?

`Reply Or Comment!
Please LogIn to Reply!